Distributor widget issues
Incident Report for Mews
Resolved
We have resolved all issues related to the Distributor Booking Engine. Many thanks for your patience.
Posted Aug 10, 2017 - 12:14 CEST
Investigating
We are currently investigating possible issues with our booking widget.
Posted Aug 10, 2017 - 10:52 CEST