Stripe payment gateway has elevated error rate of their API
Incident Report for Mews
Resolved
Stipe has resolved the issue, we can confirm that everything is operational.
Posted 2 months ago. Jul 10, 2019 - 19:40 CEST
Monitoring
As per https://status.stripe.com/, Stripe has noticed elevated error rate and response time of their API. They are working on getting it fixed.

There is nothing we can do on our side.
Posted 2 months ago. Jul 10, 2019 - 19:02 CEST
This incident affected: Payment Gateways.