Delays in processing channel managers reservations
Incident Report for Mews
Postmortem

Problem 

Channel manager reservation creation, modification and cancellation were slowed down by 2 hours. The slowdown affected around 50% of all properties with exception of properties using SiteMinder integration. Despite the problem, Mews processed all reservation messages, but with the delay. 

Action 

Once the problem was detected, we enabled alternative reservations processing to minimize the consequences and allow us time to solve the root cause issue.  

Causes 

Due to non-simultaneous reservation confirmation from certain Channel manager partners, Mews kept requesting the same reservations. This created a reservation queue with over 6000 updates and became the main reason for slowdown.  

Solutions 

 We changed the way we queue and confirm reservations to avoid the slowdowns in the future.

Posted Nov 22, 2021 - 17:20 CET

Resolved
Mews experienced issues with channel manager reservations, which led to delays in processing reservations and multiple notification emails. All reservations were processed and the issue has been fixed.
Posted Nov 04, 2021 - 17:00 CET