Connector application update issue
Incident Report for Mews
Resolved
We've identified all impacted clients and provided them with information how to resolve the issue.
Posted over 1 year ago. Jan 17, 2018 - 12:21 CET
Identified
Currently we are experiencing an issue with the new version of Connector application (application that facilitates printing and key cutting). If you are affected by this issue, please contact our support at support@mewssystems.com who'll provide you with further details how to resolve it.
Posted over 1 year ago. Jan 16, 2018 - 17:16 CET