Degraded performance.
Incident Report for Mews
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 20:35 CEST
Investigating
We are currently investigating this issue.
Posted Oct 08, 2021 - 19:38 CEST
This incident affected: Operations, Guest Journey, Business Intelligence, Payments, Open API, and Marketplace.