System accessibility
Incident Report for Mews
Postmortem

Upon further investigation, this incident was rather a false alarm and its root cause is same as in case of https://status.mews.li/incidents/v6tm1k95dnny where some pages of the system, particularly reservation module, were not accessible. We deeply apologize for the problem, we’re fully aware how annoying it is when the system is not running, especially during peak check-in or check-out hours. We’re committed to improving it, making it better and learning from our mistakes, therefore we’ll provide detailed postmortem as part of incident https://status.mews.li/incidents/v6tm1k95dnny where we’ll analyze in detail what happened and all the steps that we will put in place in order to ensure, similar things won’t happen again.

Our availability monitoring tool not only checks that the server responds when you access www.mews.li, but also checks that the response is correct, in our case that it contains “Sign In“ text. As part of our ongoing efforts to speed up the system, we were switching Commander technologically from server-side rendered pages to single-page application. Consequence of this is, that the response for sign-in page no longer contains any texts or content, it contains just the application that is responsible for rendering of the whole sign-in screen. Therefore the availability monitoring tool incorrectly detected, that something is wrong with the sign-in page, even though there was nothing wrong.

Posted Sep 24, 2019 - 23:03 CEST

Resolved
Issue has been resolved. Everything is working correctly.
Posted Sep 24, 2019 - 21:41 CEST
Monitoring
We have redirected traffic from one azure application to another, which resolved the issue. We keep monitoring the situation and discussing root cause of the problem with our cloud provider Microsoft Azure.
Posted Sep 24, 2019 - 19:26 CEST
Investigating
It appears we are not currently accessible from certain parts of the world. We are investigating the cause and looking into possible solutions.
Posted Sep 24, 2019 - 19:09 CEST
This incident affected: Operations.