Incorrect closing rates on Channel managers
Incident Report for Mews
Postmortem

First of all, we would like to apologize for all the problems this issue caused to you. This was our failure and we’ll do as much as we can to prevent anything similar from occurring again. Here is a full postmortem describing the root causes and solutions we will put in place.

Problem

A feature update to restrictions in Mews Commander at 11:45 UTC on 21st October introduced a restrictions bug that was fixed at 13:19 UTC on 22nd October. For 1 day, 1 hour, and 24 minutes any restrictions created in Mews were sent to the channel manager incorrectly.

Action

At 10:31 UTC on 22nd October, the bug was reported by our Customer Care team. Our developers immediately built and deployed a fix. And resent correct restrictions to all channel managers for all properties.

Causes

  1. Some of the automated tests for restrictions in channel managers were temporarily disabled. The restrictions feature wasn't automatically tested for channel managers. Manual smoke tests were not done for all channel managers and possible restrictions combinations.
  2. One of the automated tests in Mews Commander was incorrect. Length of stay restrictions weren't tested correctly in Commander.

Solutions

  1. Rewriting disabled channel manager tests so they work correctly.
  2. Correcting Commander restriction tests so all restriction combinations are correctly tested.
Posted Apr 03, 2020 - 12:09 CEST

Resolved
The incident has been resolved and we are currently sending updates for all affected Channel Manager connections.
Posted Oct 22, 2019 - 15:19 CEST
Monitoring
We have verifed the fix and are deploying it. We will then continue with synchronizing the inventory for affected rates.
Posted Oct 22, 2019 - 13:46 CEST
Identified
We have identified a bug in inventory pushes in channel managers, that incorrectly closes some rates. We have found the cause and are testing the fix for it. We will deploy it immediately after the fix is verifeid.

After that, we will repush all inventory updates from our side to synchronize all inventory to correct state.

We will keep you updated about the state.
Posted Oct 22, 2019 - 12:17 CEST
This incident affected: Channel Managers.