Downgraded Performance
Incident Report for Mews
Resolved
We have identified and addressed the issue. The system performance should be back at normal.
Posted Mar 18, 2024 - 17:15 CET
Investigating
We have noticed a degraded performance of the system. We are currently looking into it.

Thank you for your patience.
Posted Mar 18, 2024 - 16:44 CET